Opened 6 years ago

Closed 6 years ago

#168 closed defect (fixed)

Clarify behavior of polar and complex representations

Reported by: arcfide Owned by: alexshinn
Priority: minor Milestone: Second Public Draft
Component: WG1 - Numerics Keywords:
Cc:

Description

From Malcolm Tredinnick:

If you mean the grammar specification in the <complex> production on page 13 of the R6RS report, then that's the same as in R7RS draft 1 and is similar all the way back to at least R4RS. However, the problem is that it's only describing a bunch of symbols, not semantics. That's not enough information for an implementer or for somebody wanting to verify correct behaviour. Nowhere is it mentioned that this *is* the polar form, for example, let alone whether the number after the "@" is interpreted as radians or degrees or even possibly pineapples.

You cannot come to a recent Scheme report and get any understanding of what 1@2 actually means.

Change History (1)

comment:1 Changed 6 years ago by alexshinn

  • Resolution set to fixed
  • Status changed from new to closed

This is uncontroversial and has been updated in the draft.

Note: See TracTickets for help on using tickets.