Opened 6 years ago

Closed 6 years ago

#193 closed defect (wontfix)

values and procedure arguments

Reported by: medernac Owned by: alexshinn
Priority: major Milestone:
Component: WG1 - Core Keywords:
Cc:

Description

Why not specifying that arguments in a procedure call should evaluate to exactly one value ?

Similarly binding init would evaluate to only one value.

Change History (4)

comment:1 Changed 6 years ago by arcfide

IMO, better to take the R6RS language that the continuations of the arguments to a procedure call expect a single value, and that passing multiple values to a single-value continuation context is unspecified.

comment:2 Changed 6 years ago by alexshinn

  • Resolution set to worksforme
  • Status changed from new to closed

The R5RS (and current draft) make it very specific that
passing MV to a continuation other than that created by
call-with-values is an error. Unless you want to
strengthen this and require it to signal an error (thus
making extensions like the CL MV behavior) then there's
nothing to vote on.

comment:3 Changed 6 years ago by medernac

  • Resolution worksforme deleted
  • Status changed from closed to reopened

No, the problem is about allowing or not values to interfere with another one.
For instance :

((lambda (X Y) ...) (values A B) (values))

Do we allow implementations to bind A to X and B to Y ?

comment:4 Changed 6 years ago by cowan

  • Resolution set to wontfix
  • Status changed from reopened to closed

WG1 rejected this proposal.

Note: See TracTickets for help on using tickets.