Opened 6 years ago

Closed 6 years ago

#228 closed defect (duplicate)

DEFINE-LIBRARY to replace MODULE

Reported by: cowan Owned by: alexshinn
Priority: major Milestone:
Component: WG1 - Core Keywords:
Cc:

Description

Emails from Aaron Hsu and Denis Washington:

[AH] I do not buy the argument that we are making things better by using module instead of library in this case. The module term is much more common throughout, including systems in Chez, PLT, Scheme48 (I believe), among others.

[...]

[DW] (Bigloo and Chicken are two others which use module for existing forms.) I feel that clashing with all of these implementations substantially increases the burden for these systems' implementors to adopt to R7RS.

[...]

[DW] What about define-library? It might be slightly confusing as it sounds a bit procedural for a purely syntactic construct, but it does not seem to clash with any existing implementation (as far as a quick Google search reveals, at least [as well as direct testing --JC]) and preserves the "library" term, which is common, well-known, clear and in line with previous Scheme specs (R6RS and, in a way, R5RS' usage of the term "library procedure").

Change History (1)

comment:1 Changed 6 years ago by alexshinn

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #102.

Note: See TracTickets for help on using tickets.