Opened 6 years ago

Closed 5 years ago

#303 closed defect (fixed)

"lazy" is a confusing name

Reported by: alexshinn Owned by: cowan
Priority: major Milestone:
Component: WG1 - Core Keywords:

Description (last modified by cowan)

[Based on feedback from Marc Feeley.]

delay and force were simple balanced concepts, but the introduction of lazy somewhat confuses the issue - when is delay appropriate and when is lazy? A simple solution would be to rename lazy to delay-force, indicating it is simply the composition of delay and force, and letting people see directly in code the balance of delays and forces.

Change History (4)

comment:1 Changed 6 years ago by cowan

  • Description modified (diff)
  • Summary changed from lazy and eager names are confusing to "lazy" is a confusing name

Removing discussion of eager to ticket #307

comment:2 Changed 5 years ago by cowan

  • Status changed from new to decided

The WG voted to adopt this proposal.

comment:3 Changed 5 years ago by cowan

  • Owner changed from alexshinn to cowan
  • Status changed from decided to writing

comment:4 Changed 5 years ago by cowan

  • Resolution set to fixed
  • Status changed from writing to closed
Note: See TracTickets for help on using tickets.