Opened 6 years ago

Closed 5 years ago

#307 closed defect (fixed)

"eager" is a confusing name

Reported by: cowan Owned by: cowan
Priority: major Milestone:
Component: WG1 - Core Keywords:


[Based on feedback from Marc Feeley]

The eager procedure is named particularly unfortunately because it sounds as though it is in some way paired with lazy, and there is anecdotal evidence it was voted in on this misunderstanding. In fact, it is completely unrelated to lazy, being just a utility procedure that has never been seen used in practice. Perhaps a better name for it would be promise or make-promise, since it just creates an (already computed) promise value.

Change History (3)

comment:1 Changed 5 years ago by cowan

  • Status changed from new to decided

The WG voted to adopt this proposal, using the name make-promise.

comment:2 Changed 5 years ago by cowan

  • Owner changed from alexshinn to cowan
  • Status changed from decided to writing

comment:3 Changed 5 years ago by cowan

  • Resolution set to fixed
  • Status changed from writing to closed
Note: See TracTickets for help on using tickets.