|Reported by:||cowan||Owned by:||cowan|
|Component:||WG1 - Core||Keywords:|
(bytevector-copy! from to) is equivalent to (bytevector-copy-partial from 0 (bytevector-length) to 0). I don't see any reason to believe that this case is so special that it needs its own name.
I suggest that we remove the existing bytevector-copy! from the small language, and rename bytevector-copy-partial! to bytevector-copy!, with the order of arguments to at from start end, the same order used in SRFI 43's vector-copy!. Note that SRFI 43 will be part of the large language.