Opened 5 years ago

Closed 5 years ago

#435 closed defect (wontfix)

Formal Comment: Bytevectors should be called u8vectors

Reported by: cowan Owned by: cowan
Priority: major Milestone:
Component: WG1 - Core Keywords:
Cc:

Description

Submitter's name: Marc Feeley

Submitter's email: feeley at iro.umontreal.ca

Relevant draft: r7rs draft 6

Type: defect

Priority: minor

Relevant section of draft: 6.9. Bytevectors

Summary: Bytevectors should be called u8vectors

Many implementations of Scheme have adopted SRFI-4 where bytevectors are called u8vectors, and where the procedures operating on bytevectors have u8vector in their name.

I see no reason to introduce new names. It will require many implementations to implement the new names, and moreover the SRFI-4 names will have to be kept for code which uses SRFI-4. This is needless bloat.

The name u8vector is a very mnemonic way of expressing verbally the external representation #u8(...) which is used by R7RS for bytevectors.

I also find the names bytevector-u8-ref and bytevector-u8-set! very clumsy and verbose compared to u8vector-ref and u8vector-set!.

Change History (4)

comment:1 Changed 5 years ago by cowan

  • Resolution set to wontfix
  • Status changed from new to closed

We voted for bytevector explicitly, and no new arguments have been given here. It would be inconsistent to use u8vector-ref given bytevector; the reason not to use simple bytevector-ref is for upward compatibility with BlobAPI or whatever replaces it.

comment:2 Changed 5 years ago by cowan

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:3 Changed 5 years ago by cowan

  • Owner changed from alexshinn to cowan
  • Status changed from reopened to accepted

comment:4 Changed 5 years ago by cowan

  • Resolution set to wontfix
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.